You Are Here: Home » Info » -Info Ipv6 » EIGRP for IPv6 (EIGRPv2) over Frame Relay

EIGRP for IPv6 (EIGRPv2) over Frame Relay

EIGRP for IPv6 (EIGRPv2) over Frame Relay

 

 Hub router-

ipv6 unicast-routing
ipv6 cef
!
interface serial 1/0
no ip address
encapsulation frame-relay
!
interface serial 1/0.1 multipoint
ipv6 address FE80::1 link-local
ipv6 address 2001::1/124
frame-relay interface-dlci 102
frame-relay interface-dlci 103
frame-relay map ipv6 2001::2 102 broadcast
frame-relay map ipv6 FE80::2 102
frame-relay map ipv6 2001::3 103 broadcast
frame-relay map ipv6 FE80::3 103
 ipv6 eigrp 10
no ipv6 split-horizon eigrp 10
ipv6 summary-address eigrp 10 CAFE::/126

!
ipv6 router eigrp 10
router-id 1.1.1.1
no shutdown

!

 Spoke1 router-

ipv6 unicast-routing
ipv6 cef
!
interface serial 1/0
no ip address
encapsulation frame-relay
!
interface serial 1/0.201 multipoint
ipv6 address FE80::2 link-local
ipv6 address 2001::2/124
frame-relay interface-dlci 201
frame-relay map ipv6 2001::1 201 broadcast
frame-relay map ipv6 FE80::1 201
frame-relay map ipv6 2001::3 201 broadcast
frame-relay map ipv6 FE80::3 201
ipv6 eigrp 10
!
ipv6 router eigrp 10
router-id 2.2.2.2
no shutdown

!

 Spoke2 router-

ipv6 unicast-routing
ipv6 cef
!
interface Loopback 0
ipv6 address CAFE::1/128
ipv6 eigrp 10
!
interface Loopback 1
ipv6 address CAFE::2/128
ipv6 eigrp 10
!
interface Loopback 2
ipv6 address CAFE::3/128
ipv6 eigrp 10
!
interface Loopback 3
ipv6 address CAFE::4/128
ipv6 eigrp 10
!
interface Loopback 4
ipv6 address CAFE::5/128
ipv6 eigrp 10
!
interface serial 1/0
no ip address
encapsulation frame-relay
!
interface serial 1/0.301 multipoint
ipv6 address FE80::3 link-local
ipv6 address 2001::3/124
frame-relay interface-dlci 301
frame-relay map ipv6 2001::1 301 broadcast
frame-relay map ipv6 FE80::1 301
frame-relay map ipv6 2001::2 301 broadcast
frame-relay map ipv6 FE80::2 301
 ipv6 eigrp 10
!
ipv6 router eigrp 10
router-id 3.3.3.3
no shutdown

!

EIGRP is enabled on per-interface basis using ipv6 eigrp <AS_number> command. However, from the EIGRP router configuration, the router-id is compulsory. Further, by default the EIGRP process is shutdown and hence needs to be enabled manually using no shutdown command from EIGRP router configuration mode.

The following command shows the protocols enabled on the Hub router. It also shows the “K values” used by EIGRP.

Hub# show ipv6 protocols
IPv6 Routing Protocol is “connected”
IPv6 Routing Protocol is “static”
IPv6 Routing Protocol is “eigrp 10”
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Interfaces:
Serial1/0.1
Redistribution:
None
Address Summarization:
CAFE::/126 for Serial1/0.1
Summarizing with metric 2297856
Maximum path: 16
Distance: internal 90 external 170

When the EIGRP process is enabled, it starts to send out Hello messages with multicast address FF02::A (by default, once every 5 seconds on broadcast network and 60 seconds on other networks).

Once EIGRP processes are enabled on Spoke1 and Spoke2 routers, the EIGRP adjacency is established. It can be seen below that EIGRPv2 uses link-local addresses to form neighbor relationship (like OSPFv3).

Hub# debug ipv6 eigrp
*Mar  1 00:41:14.707: %DUAL-5-NBRCHANGE: IPv6-EIGRP(0) 10: Neighbor FE80::2 (Serial1/0.1) is up: new adjacency
*Mar  1 00:47:36.967: %DUAL-5-NBRCHANGE: IPv6-EIGRP(0) 10: Neighbor FE80::3 (Serial1/0.1) is up: new adjacency

Hub# show ipv6 eigrp neighbors
IPv6-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime       SRTT   RTO  Q  Seq
(sec)            (ms)           Cnt Num
1   Link-local address:     Se1/0.1          160 00:00:19   74   444      0    11
FE80::3
0   Link-local address:     Se1/0.1          166 00:06:42  107   642     0     6
FE80::2

Spoke1 and Spoke2 routers only form EIGRP neighbor relationship with Hub router.

Spoke1# show ipv6 eigrp neighbors

IPv6-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime       SRTT   RTO  Q      Seq
(sec)             (ms)          Cnt     Num
0   Link-local address:     Se1/0.201        162 00:16:44 1302  5000  0        13
FE80::1

Spoke2# show ipv6 eigrp neighbors
IPv6-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q       Seq
(sec)         (ms)           Cnt     Num
0   Link-local address:     Se1/0.301        170 01:04:12  146   876  0       23
FE80::1

Before summarization, the IPv6 routing table of Spoke1 router shows all individual Loopback prefixes of Spoke2 router.

Spoke1# show ipv6 route
IPv6 Routing Table – 8 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
U – Per-user Static route, M – MIPv6
I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary
O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2
ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2
D – EIGRP, EX – EIGRP external
C   2001::/124 [0/0]
via ::, Serial1/0.201
L   2001::2/128 [0/0]
via ::, Serial1/0.201
D   CAFE::1/128 [90/2809856]
via FE80::1, Serial1/0.201
D   CAFE::2/128 [90/2809856]
via FE80::1, Serial1/0.201
D   CAFE::3/128 [90/2809856]
via FE80::1, Serial1/0.201
D   CAFE::4/128 [90/2809856]
via FE80::1, Serial1/0.201
D   CAFE::5/128 [90/2809856]
via FE80::1, Serial1/0.201

L   FF00::/8 [0/0]
via ::, Null0

However, when summary-address is configured on Hub router, the EIGRP adjacency goes down and comes up again.

Hub(config-subif)#ipv6 summary-address eigrp 10 CAFE::/126
Hub(config-subif)#
*Mar  1 01:03:44.071: %DUAL-5-NBRCHANGE: IPv6-EIGRP(0) 10: Neighbor FE80::3 (Serial1/0.1) is down: summary configured
*Mar  1 01:03:44.087: %DUAL-5-NBRCHANGE: IPv6-EIGRP(0) 10: Neighbor FE80::2 (Serial1/0.1) is down: summary configured
Hub(config-subif)#
*Mar  1 01:04:13.231: %DUAL-5-NBRCHANGE: IPv6-EIGRP(0) 10: Neighbor FE80::2 (Serial1/0.1) is up: new adjacency
*Mar  1 01:04:13.395: %DUAL-5-NBRCHANGE: IPv6-EIGRP(0) 10: Neighbor FE80::3 (Serial1/0.1) is up: new adjacency

Spoke1#
*Mar  1 01:04:11.383: %DUAL-5-NBRCHANGE: IPv6-EIGRP(0) 10: Neighbor FE80::1 (Serial1/0.201) is up: new adjacency
*Mar  1 01:04:13.331: IPv6-EIGRP(0:10): Processing incoming UPDATE packet
*Mar  1 01:04:13.331: IPv6-EIGRP(0:10): 2001::/124 Рdo advertise out Serial1/0.201
*Mar  1 01:04:13.331: IPv6-EIGRP(0:10): Int 2001::/124 metric 2169856 Р1657856 512000
*Mar  1 01:04:13.475: IPv6-EIGRP(0:10): Processing incoming UPDATE packet
*Mar  1 01:04:13.475: IPv6-EIGRP(0:10): Int 2001::/124 M 2681856 Р1657856 1024000 SM 2169856 Р1657856 512000
*Mar  1 01:04:13.475: IPv6-EIGRP(0:10): 2001::/124 routing table not updated
*Mar  1 01:04:13.479: IPv6-EIGRP(0:10): 2001::/124 Рdo advertise out Serial1/0.201
*Mar  1 01:04:13.479: IPv6-EIGRP(0:10): Int 2001::/124 metric 2169856 Р1657856 512000
*Mar  1 01:04:13.675: IPv6-EIGRP(0:10): Processing incoming UPDATE packet
*Mar  1 01:04:13.675: IPv6-EIGRP(0:10): Int 2001::/124 M 2681856 Р1657856 1024000 SM 2169856 Р1657856 512000
*Mar  1 01:04:13.771: IPv6-EIGRP(0:10): Processing incoming UPDATE packet
*Mar  1 01:04:13.775: IPv6-EIGRP(0:10): Int CAFE::4/128 M 2809856 Р1657856 1152000 SM 2297856 Р1657856 640000
*Mar  1 01:04:13.775: IPv6-EIGRP(0:10): CAFE::4/128 (90/2809856) added to RIB
*Mar  1 01:04:13.779: IPv6-EIGRP(0:10): Int CAFE::5/128 M 2809856 Р1657856 1152000 SM 2297856 Р1657856 640000
*Mar  1 01:04:13.779: IPv6-EIGRP(0:10): CAFE::5/128 (90/2809856) added to RIB
*Mar  1 01:04:13.875: IPv6-EIGRP(0:10): Processing incoming UPDATE packet
*Mar  1 01:04:13.879: IPv6-EIGRP(0:10): Int CAFE::/126 M 2809856 Р1657856 1152000 SM 2297856 Р1657856 640000
*Mar  1 01:04:13.879: IPv6-EIGRP(0:10): CAFE::/126 (90/2809856) added to RIB

Spoke1# show ipv6 route
IPv6 Routing Table – 6 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
U – Per-user Static route, M – MIPv6
I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary
O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2
ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2
D – EIGRP, EX – EIGRP external
C   2001::/124 [0/0]
via ::, Serial1/0.201
L   2001::2/128 [0/0]
via ::, Serial1/0.201
D   CAFE::/126 [90/2809856]
via FE80::1, Serial1/0.201

D   CAFE::4/128 [90/2809856]
via FE80::1, Serial1/0.201
D   CAFE::5/128 [90/2809856]
via FE80::1, Serial1/0.201
L   FF00::/8 [0/0]
via ::, Null0

About The Author

harrychanputra.web.id

Number of Entries : 295

Leave a Comment

© 2011 Powered By Wordpress, Goodnews Theme By Geeks Docuementation

Scroll to top