You Are Here: Home » Info » -Info Ipv6 » Dual Stack

Dual Stack

Dual Stack

Dual Stack is a way to implement IPv6 and still remain compatible with IPv4. A node that runs both IPv6 and IPv6 protocol stacks is called an IPv6/IPv6 node. An IPv6/IPv4 node communicates using IPv6 packets with IPv6 nodes and using IPv4 packets with IPv4 nodes.

Consider the following-

Two IPv6/IPv4 nodes, R5 and R6, are connected to each other via a Fastethernet interface. The Fastethernet interface is configured with an IPv4 as well as an IPv6 address.

 R5 router-

ipv6 unicast-routing
ipv6 cef
!
interface Loopback 0
ip address 5.5.5.5 255.255.255.255
!
interface Loopback 1
ipv6 address 2002:ABAB::/64 eui-64
ipv6 rip TEST enable
!
interface fastethernet 0/0
ip address 10.1.1.1 255.255.255.252
ipv6 address 2001::/64 eui-64
ipv6 rip TEST enable

!
router ospf 1
network 5.5.5.5 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
!
ipv6 router rip TEST
!

 R6 router-

ipv6 unicast-routing
ipv6 cef
!
interface Loopback 0
ip address 6.6.6.6 255.255.255.255
!
interface Loopback 1
ipv6 address 2003:ABAB::/64 eui-64
ipv6 rip TEST enable
!
interface fastethernet 0/0
ip address 10.1.1.2 255.255.255.252
ipv6 address 2001::/64 eui-64
ipv6 rip TEST enable

!
router ospf 1
network 6.6.6.6 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
!
ipv6 router rip TEST
!

The show ip interface brief command shows the interfaces configured with IPv4 addresses on R5.

R5# show ip interface brief
Interface                      IP-Address      OK?     Method         Status                Protocol
FastEthernet0/0            10.1.1.1           YES     NVRAM          up                    up

FastEthernet0/1            unassigned      YES     NVRAM          administratively down down

Loopback0                    5.5.5.5            YES         NVRAM      up                    up

Loopback1                   unassigned       YES         unset         up                    up

The show ipv6 interface brief command shows the interfaces configured with IPv6 addresses on R5.

R5# show ipv6 interface brief
FastEthernet0/0            [up/up]
FE80::C009:10FF:FE38:0
2001::C009:10FF:FE38:0

FastEthernet0/1            [administratively down/down]
Loopback0                  [up/up]
Loopback1                  [up/up]
FE80::C009:10FF:FE38:0
2002:ABAB::C009:10FF:FE38:0

The show ip route command shows the IPv4 routing table on R5. It shows that Loopback0 interface of R6 is reachable through Fa 0/0.

R5# show ip route | begin Gateway
Gateway of last resort is not set

5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
     6.0.0.0/32 is subnetted, 1 subnets
O       6.6.6.6 [110/20] via 10.1.1.2, 00:05:42, FastEthernet0/0

10.0.0.0/30 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

The show ipv6 route command shows the IPv6 routing table on R5. It shows that the Loopback1 interface of R6 is also reachable through Fastethernet 0/0.

R5# show ipv6 route
IPv6 Routing Table – 7 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
U – Per-user Static route
I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary
O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2
ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2
C   2001::/64 [0/0]
via ::, FastEthernet0/0
L   2001::C009:10FF:FE38:0/128 [0/0]
via ::, FastEthernet0/0
C   2002:ABAB::/64 [0/0]
via ::, Loopback1
L   2002:ABAB::C009:10FF:FE38:0/128 [0/0]
via ::, Loopback1
R   2003:ABAB::/64 [120/2]
via FE80::C00A:17FF:FE04:0, FastEthernet0/0

L   FE80::/10 [0/0]
via ::, Null0
L   FF00::/8 [0/0]
via ::, Null0

The following output shows IPv4 traffic flowing from R5 to R6 through outgoing interface Fastethernet 0/0.

The following output shows IPv6 traffic flowing from R6 to R5 through outgoing Fastethernet 0/0.

About The Author

harrychanputra.web.id

Number of Entries : 295

Leave a Comment

© 2011 Powered By Wordpress, Goodnews Theme By Geeks Docuementation

Scroll to top