You Are Here: Home » Info » -Info Ipv6 » 6PE: Crossing Multiple AS

6PE: Crossing Multiple AS

6PE: Crossing Multiple AS

RFC 4798 describes three approaches to provide communication between two IPv6 islands connected to two different BGP Autonomous Systems (AS).

These approaches are-

  1. eBGP redistribution of IPv6 routes from AS to neighboring AS
  2. eBGP redistribution of labeled IPv6 routes from AS to neighboring AS
  3. Multihop eBGP redistribution of labeled IPv6 routes between source and destination ASes, with eBGP redistribution of labeled IPv4 routes from AS to neighboring AS.

Network topology:

Approach 2:

The 6PE1 router has iBGP peering with ASBR-1 router in AS 100 and redistribute labeled IPv6 prefixes to ASBR-1 router. The ASBR-1 router then uses eBGP to redistribute non-labeled IPv6 prefixes to neighboring ASBR-2 router in AS 200, which in turn distributes them to 6PE2 router.

The inter-ASBR link is IPv6 enabled and each connected interface has an IPv6 address. There is no LSP between ASBRs.

MP-BGP Configuration on 6PE routers:

6PE1 and 6PE2 routers run eBGP session with CE1 and CE2 routers respectively. 6PE1 router also runs iBGP session with ASBR-1 router in AS 100. 6PE2 router runs iBGP session with ASBR-2 router in AS 200. ASBR-1 and ASBR-2 router also run an eBGP connection between them.

BGP Configuration on 6PE1

ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ldp router-id Loopback 0 force
mpls ipv6 source-interface Loopback 0
!
interface Loopback 0
 ip address 1.1.1.1 255.255.255.255
 ipv6 address ABCD::1/128
!
router bgp 100
 neighbor 2001:1::1 remote-as 65101
 neighbor 2001:1::1 description eBGP with CE1 router
 neighbor 3.3.3.3 remote-as 100
 neighbor 3.3.3.3 description iBGP with ASBR-1 router
 neighbor 3.3.3.3 update-source Loopback 0
 !
 address-family ipv6
 neighbor 2001:1::1 activate
 neighbor 3.3.3.3 activate
 neighbor 3.3.3.3 send-label
 redistribute connected
exit-address-family

!

 

BGP Configuration on ASBRs

ASBR-1 router:

ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ldp router-id Loopback 0 force
mpls ipv6 source-interface Loopback 0
!
interface Loopback 0
 ip address 3.3.3.3 255.255.255.255
 ipv6 address ABCD::3/128
!
router bgp 100
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 description iBGP with 6PE1 router
 neighbor 2001:3::2 remote-as 200
 neighbor 2001:3::2 description eBGP with ASBR-2 router
 !
 address-family ipv6
 neighbor 1.1.1.1 activate
 neighbor 1.1.1.1 send-label
 neighbor 2001:3::2 activate
 redistribute connected
exit-address-family

!

ASBR-2 router:

ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ldp router-id Loopback 0 force
mpls ipv6 source-interface Loopback 0
!
interface Loopback 0
 ip address 4.4.4.4 255.255.255.255
 ipv6 address ABCD::4/128
!
router bgp 200
 neighbor 2001:3::1 remote-as 100
 neighbor 2001:3::1 description eBGP with ASBR-1 router
 neighbor 6.6.6.6 remote-as 200
 neighbor 6.6.6.6 description iBGP with 6PE2 router
 neighbor 6.6.6.6 update-source Loopback 0
 !
 address-family ipv6
 neighbor 2001:3::1 activate
 neighbor 6.6.6.6 activate
 neighbor 6.6.6.6 send-label
 redistribute connected
exit-address-family

!

 

BGP Configuration on 6PE2

ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ldp router-id Loopback 0 force
mpls ipv6 source-interface Loopback 0
!
interface Loopback 0
 ip address 6.6.6.6 255.255.255.255
 ipv6 address ABCD::6/128
!
router bgp 200
 neighbor 4.4.4.4 remote-as 200
 neighbor 4.4.4.4 description iBGP with ASBR-2 router
 neighbor 4.4.4.4 update-source Loopback 0
 neighbor 2001:2::1 remote-as 65102
 neighbor 2001:2::1 description eBGP with CE2 router
 !
 address-family ipv6
 neighbor 4.4.4.4 activate
 neighbor 4.4.4.4 send-label
 neighbor 2001:2::1 activate
 redistribute connected
 exit-address-family
!

6PE1 router advertises a label for its connected IPv6 networks to ASBR-1 router via BGP. The following output shows IPv6 prefixes with their labels. IPv6 prefixes 2001:1::/124 and ABCD::1/128 are advertised by 6PE1 router. The next-hop for these IPv6 prefixes is the IPv4-mapped IPv6 address ::FFFF:1.1.1.1 of 6PE1 router. The In Label/Out Label for IPv6 prefix 2001:1::/124 is No Label/20. This indicates that there is no LSP between ASBR-1 and ASBR-2 router, because ASBR-1 router imposes label 20 if packets are destined for 2001:1::/124 network with next-hop as 6PE1 router.

IPv6 Prefixes and labels on ASBR-1

ASBR-1# show bgp ipv6 unicast labels
   Network          Next Hop      In label/Out label
   2001:1::/124     ::FFFF:1.1.1.1  nolabel/20
   2001:3::/124     2001:3::2       21/nolabel
                    ::              21/nolabel
   ABCD::1/128      ::FFFF:1.1.1.1  nolabel/19
   ABCD::3/128      ::              19/nolabel
   ABCD::4/128      2001:3::2       20/nolabel
   ABCD::6/128      2001:3::2       22/nolabel

Similarly, on ASBR-2 router, the In Label/Out Label for IPv6 prefix 2001:1::/124 is 23/No Label. This also indicates that there is no LSP between ASBR-2 and ASBR-1 router as the Out Label is No Label. However, the In Label is Label 23 which it will advertise to 6PE2 router via BGP.

IPv6 Prefixes and labels on ASBR-2

ASBR-2# show bgp ipv6 unicast labels
   Network          Next Hop      In label/Out label
   2001:1::/124     2001:3::1       23/nolabel
   2001:3::/124     ::              20/nolabel
                    2001:3::1       20/nolabel
   ABCD::1/128      2001:3::1       22/nolabel
   ABCD::3/128      2001:3::1       21/nolabel
   ABCD::4/128      ::              19/nolabel
   ABCD::6/128      ::FFFF:6.6.6.6  nolabel/19

The following output shows the labels that will be imposed by 6PE2 router to reach IPv6 prefix 2001:1::/124 connected to 6PE1 and CE1 routers. The top label Label 16 is the IGP label while the bottom Label 23 is the BGP VPNv4 label advertised by ASBR-2 router.

Labels imposed by 6PE2

6PE2# show bgp ipv6 unicast labels
   Network          Next Hop      In label/Out label
   2001:1::/124     ::FFFF:4.4.4.4  nolabel/23
   2001:3::/124     ::FFFF:4.4.4.4  nolabel/20
   ABCD::1/128      ::FFFF:4.4.4.4  nolabel/22
   ABCD::3/128      ::FFFF:4.4.4.4  nolabel/21
   ABCD::4/128      ::FFFF:4.4.4.4  nolabel/19
   ABCD::6/128      ::              19/nolabel

6PE2# show ip cef 4.4.4.4
4.4.4.4/32, version 12, epoch 0, cached adjacency 10.2.2.5
0 packets, 0 bytes
  tag information set
    local tag: 17
    fast tag rewrite with Fa0/0, 10.2.2.5, tags imposed: {16}
  via 10.2.2.5, FastEthernet0/0, 0 dependencies
    next hop 10.2.2.5, FastEthernet0/0
    valid cached adjacency
    tag rewrite with Fa0/0, 10.2.2.5, tags imposed: {16}

6PE2# show ipv6 cef 2001:1::
2001:1::/124
nexthop ::FFFF:4.4.4.4
fast tag rewrite with Fa0/0, 10.2.2.5, tags imposed: {16 23}

 

About The Author

harrychanputra.web.id

Number of Entries : 295

Leave a Comment

© 2011 Powered By Wordpress, Goodnews Theme By Geeks Docuementation

Scroll to top